summaryrefslogtreecommitdiff
path: root/cross-project-tests/CMakeLists.txt
diff options
context:
space:
mode:
authorOCHyams <orlando.hyams@sony.com>2021-12-16 13:41:29 +0000
committerOCHyams <orlando.hyams@sony.com>2021-12-16 13:43:04 +0000
commit18ee898cfad21d6879bfd631ca39522ab5692413 (patch)
tree07b968b4c86e1f018d0fe7461916df0bc149bb75 /cross-project-tests/CMakeLists.txt
parent8561e15c5befd84542637493a76c8f2de25d08b9 (diff)
downloadllvm-18ee898cfad21d6879bfd631ca39522ab5692413.tar.gz
[Dexter] Remove the Windows dependency on lld from CMake
Currently, lld is marked as a dependency on Windows in cross-project-tests/CMakeLists.txt which means CMake will fail if lld isn't enabled. The idea of the cross-project-tests is that tests that don't have their dependencies met should just be unsupported. Remove the depenency from the CMake step and check whether Dexter's platform-specific dependencies have been met in cross-project-tests/lit.cfg.py. If the dependencies are met then add 'dexter' to the available_features, otherwise don't and the dexter tests will be "UNSUPPORTED". Reviewed By: jhenderson Differential Revision: https://reviews.llvm.org/D115872
Diffstat (limited to 'cross-project-tests/CMakeLists.txt')
-rw-r--r--cross-project-tests/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/cross-project-tests/CMakeLists.txt b/cross-project-tests/CMakeLists.txt
index 0d55e9681a10..ed74aabde0d9 100644
--- a/cross-project-tests/CMakeLists.txt
+++ b/cross-project-tests/CMakeLists.txt
@@ -55,8 +55,7 @@ if("lldb" IN_LIST LLVM_ENABLE_PROJECTS)
list(APPEND CROSS_PROJECT_TEST_DEPS lldb lldb-server)
endif()
-# The Windows builder scripts pass -fuse-ld=lld.
-if (WIN32 OR "lld" IN_LIST LLVM_ENABLE_PROJECTS)
+if ("lld" IN_LIST LLVM_ENABLE_PROJECTS)
list(APPEND CROSS_PROJECT_TEST_DEPS lld)
endif()