summaryrefslogtreecommitdiff
path: root/cross-project-tests/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Lively <tlively@google.com>2022-03-17 15:22:17 -0700
committerThomas Lively <tlively@google.com>2022-03-17 15:22:17 -0700
commit7062094bbc68d31218fe2e733124fdc2977f50af (patch)
treefe8cb1ab3833cda820cf29b7e445c0cffb1e68cf /cross-project-tests/CMakeLists.txt
parent6316129e066e0a252430699f2b41706d4808476c (diff)
downloadllvm-7062094bbc68d31218fe2e733124fdc2977f50af.tar.gz
[WebAssembly] Add end-to-end codegen tests for wasm_simd128.h
Add a test checking that each SIMD intrinsic produces the expected instruction. Since this test spans both clang and LLVM, place it in a new intrinsic-header-tests subdirectory of cross-project-tests. This revives D101684 now that cross-project-tests exists. In practice, the tests of lowering from wasm_simd128.h to LLVM IR were not as useful as this end-to-end test. Updates the version check of gdb in cross-project-tests/lit.cfg.py so that unexpected version formats do not prevent the new tests from running. Depends on D121661. Differential Revision: https://reviews.llvm.org/D121662
Diffstat (limited to 'cross-project-tests/CMakeLists.txt')
-rw-r--r--cross-project-tests/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/cross-project-tests/CMakeLists.txt b/cross-project-tests/CMakeLists.txt
index ed74aabde0d9..af857e766275 100644
--- a/cross-project-tests/CMakeLists.txt
+++ b/cross-project-tests/CMakeLists.txt
@@ -78,6 +78,13 @@ add_lit_testsuite(check-debuginfo "Running debuginfo tests"
DEPENDS ${CROSS_PROJECT_TEST_DEPS}
)
+# Add alias for intrinsic header test subset.
+add_lit_testsuite(check-intrinsic-headers "Running intrinsic header tests"
+ ${CMAKE_CURRENT_BINARY_DIR}/intrinsic-header-tests
+ EXCLUDE_FROM_CHECK_ALL
+ DEPENDS ${CROSS_PROJECT_TEST_DEPS}
+ )
+
# Add check-cross-project-* targets.
add_lit_testsuites(CROSS_PROJECT ${CMAKE_CURRENT_SOURCE_DIR}
DEPENDS ${CROSS_PROJECT_TEST_DEPS}
@@ -85,3 +92,4 @@ add_lit_testsuites(CROSS_PROJECT ${CMAKE_CURRENT_SOURCE_DIR}
set_target_properties(check-cross-project PROPERTIES FOLDER "Tests")
set_target_properties(check-debuginfo PROPERTIES FOLDER "Tests")
+set_target_properties(check-intrinsic-headers PROPERTIES FOLDER "Tests")