summaryrefslogtreecommitdiff
path: root/flang/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorEthan Luis McDonough <ethanluismcdonough@gmail.com>2023-03-17 02:26:51 -0500
committerEthan Luis McDonough <ethanluismcdonough@gmail.com>2023-03-17 02:28:59 -0500
commitbde91fd03f72a25151caa9f8ee2d4572ff14619b (patch)
tree8b7181e4d68b4f3515b653dfdd61b0c847d564b6 /flang/examples/CMakeLists.txt
parentbb0548a6edf0027eca8d92e021c45afd51b29c9e (diff)
downloadllvm-bde91fd03f72a25151caa9f8ee2d4572ff14619b.tar.gz
[flang] Feature list plugin
Plugin that counts the number of times each tree node occurs in a given program. Used for test coverage. > One thing we need...is a way to determine what features a code uses. Preferably we would also be able to determine if they are implemented or not. Just the former could be done with a visitor for the parse tree. For the latter we would continue compilation and somehow ignore todo errors but collect them - @jdoerfert Reviewed By: jdoerfert Differential Revision: https://reviews.llvm.org/D143704
Diffstat (limited to 'flang/examples/CMakeLists.txt')
-rw-r--r--flang/examples/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/flang/examples/CMakeLists.txt b/flang/examples/CMakeLists.txt
index 23fea3920efb..8cc66ddbbbb0 100644
--- a/flang/examples/CMakeLists.txt
+++ b/flang/examples/CMakeLists.txt
@@ -1,3 +1,4 @@
add_subdirectory(ExternalHelloWorld)
add_subdirectory(PrintFlangFunctionNames)
add_subdirectory(FlangOmpReport)
+add_subdirectory(FeatureList)