summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorSiva Chandra Reddy <sivachandra@google.com>2023-01-28 09:26:46 +0000
committerSiva Chandra Reddy <sivachandra@google.com>2023-01-30 16:39:41 +0000
commit23872aae129ce0282477c6838707569315f41585 (patch)
tree9550452b8ca629a788ea0cfb9c0a1eaff1432cc6 /libc/CMakeLists.txt
parent12b65a66fc20ddeed88df0c5d74a7ab3e9a0a382 (diff)
downloadllvm-23872aae129ce0282477c6838707569315f41585.tar.gz
[libc] Add an off-by-default option to silence "skipping" messages from CMake.
Reviewed By: lntue Differential Revision: https://reviews.llvm.org/D142802
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index a293286a4f6d..38fe16a3c26c 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -31,6 +31,8 @@ if(LLVM_ENABLE_RUNTIMES AND NOT LLVM_RUNTIMES_BUILD)
return()
endif()
+option(LIBC_CMAKE_VERBOSE_LOGGING
+ "Log details warnings and notifications during CMake configuration." OFF)
# Path libc/scripts directory.
set(LIBC_BUILD_SCRIPTS_DIR "${LIBC_SOURCE_DIR}/utils/build_scripts")