summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Bailey <jeffbailey@google.com>2022-01-29 00:27:34 +0000
committerJeff Bailey <jeffbailey@google.com>2022-01-29 00:29:31 +0000
commit4465c299069f3ff5b93ba648edf699faf7f39e79 (patch)
treee8bb62afd04432d484ca069dc2382a2d5f84fe86 /libc/CMakeLists.txt
parenteb933225f491e2063ba47e18a1153829cb32676c (diff)
downloadllvm-4465c299069f3ff5b93ba648edf699faf7f39e79.tar.gz
Move LLVM Proposal to doc directory, create index
The LLVM Libc project is no longer just a proposal and should have a webpage tracking the status of the project. This changes puts the pieces into the right place so that the webpage can be created. Reviewed By: sivachandra Differential Revision: https://reviews.llvm.org/D117436
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index 95467959af8d..f9836877addf 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -80,6 +80,8 @@ if(LLVM_LIBC_INCLUDE_SCUDO)
endif()
endif()
+option(LIBC_INCLUDE_DOCS "Build the libc documentation." ${LLVM_INCLUDE_DOCS})
+
include(CMakeParseArguments)
include(LLVMLibCRules)
include(LLVMLibCCheckCpuFeatures)
@@ -138,3 +140,7 @@ if(LLVM_INCLUDE_TESTS)
endif()
add_subdirectory(benchmarks)
+
+if (LIBC_INCLUDE_DOCS)
+ add_subdirectory(docs)
+endif()