summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorDominic Chen <ddchen@apple.com>2022-09-29 14:57:56 -0700
committerDominic Chen <ddchen@apple.com>2022-10-05 16:23:19 -0700
commit5470b1fcb5754b45c1233df7759411ff56942d6e (patch)
tree3f7b6c022bbf7a2ae7d3cd4b21e64e93090475e1 /libc/CMakeLists.txt
parent1b27484a49ac12a5dad632e633c1c77b4281545d (diff)
downloadllvm-5470b1fcb5754b45c1233df7759411ff56942d6e.tar.gz
[libc] Resolve NaN/implementation-defined behavior of floating-point tests
Differential Revision: https://reviews.llvm.org/D134917
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index 2c403b98cf41..eff5e00453f5 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -49,7 +49,7 @@ else()
endif()
option(LLVM_LIBC_FULL_BUILD "Build and test LLVM libc as if it is the full libc" OFF)
-
+option(LLVM_LIBC_IMPLEMENTATION_DEFINED_TEST_BEHAVIOR "Build LLVM libc tests assuming our implementation-defined behavior" ON)
option(LLVM_LIBC_ENABLE_LINTING "Enables linting of libc source files" OFF)
if(LLVM_LIBC_CLANG_TIDY)