summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorSiva Chandra Reddy <sivachandra@google.com>2023-04-24 23:07:22 +0000
committerSiva Chandra Reddy <sivachandra@google.com>2023-04-24 23:21:43 +0000
commit7b37f732783e9b8270cbb63ff95618594dbe011b (patch)
tree92ec15ca9aa5bb16483e7cf57e897b35f02ea8e3 /libc/CMakeLists.txt
parenta971bc38cee892fb490b806eec74f2188fb70416 (diff)
downloadllvm-7b37f732783e9b8270cbb63ff95618594dbe011b.tar.gz
[libc][Obvious] Enable hermetic tests only under full build.
Reviewed By: jhuber6 Differential Revision: https://reviews.llvm.org/D149105
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index da669a1d5e58..e0e5b69b47cf 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -76,7 +76,7 @@ option(LIBC_GPU_BUILD "Build libc for the GPU. All CPU build options will be ign
set(LIBC_TARGET_TRIPLE "" CACHE STRING "The target triple for the libc build.")
set(LIBC_ENABLE_UNITTESTS ON)
-set(LIBC_ENABLE_HERMETIC_TESTS ON)
+set(LIBC_ENABLE_HERMETIC_TESTS ${LLVM_LIBC_FULL_BUILD})
# Defines LIBC_TARGET_ARCHITECTURE and associated macros.
include(LLVMLibCArchitectures)