summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorSiva Chandra Reddy <sivachandra@google.com>2022-08-19 07:01:47 +0000
committerSiva Chandra Reddy <sivachandra@google.com>2022-08-19 07:07:30 +0000
commit857286f757ee6e4f8fe0e701f9957a4510af2d93 (patch)
tree35c12e30e5f9e55e9ee9aacc29d5042ea4ebe83c /libc/CMakeLists.txt
parent00fa513c0351325465472ed7a51e47da36ceb100 (diff)
downloadllvm-857286f757ee6e4f8fe0e701f9957a4510af2d93.tar.gz
[libc][NFC] Change the libc fullbuild target name to "libc".
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index 8aca93b2cf7c..aaf4b153c397 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -146,15 +146,17 @@ set(LIBC_COMPONENT)
set(LIBC_INSTALL_DEPENDS)
set(LIBC_INSTALL_TARGET)
if(LLVM_LIBC_FULL_BUILD)
- set(LIBC_TARGET c)
+ set(LIBC_TARGET libc)
set(LIBC_COMPONENT libc)
- set(LIBC_INSTALL_DEPENDS "c;libc-headers")
+ set(LIBC_INSTALL_DEPENDS "libc;libc-headers")
set(LIBC_INSTALL_TARGET install-libc)
+ set(LIBC_ARCHIVE_NAME c)
else()
set(LIBC_TARGET llvmlibc)
set(LIBC_COMPONENT llvmlibc)
set(LIBC_INSTALL_DEPENDS llvmlibc)
set(LIBC_INSTALL_TARGET install-llvmlibc)
+ set(LIBC_ARCHIVE_NAME llvmlibc)
endif()
add_subdirectory(include)