summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorYannic Bonenberger <yannic.bonenberger@gmail.com>2022-01-19 10:34:03 -0800
committerMichael Jones <michaelrj@google.com>2022-01-19 10:39:34 -0800
commita01523ea9939ba360ddca94786134b91189ce42f (patch)
tree7833e1a736c1745334bc51361625d4a0e1aa016e /libc/CMakeLists.txt
parentccb09a48891fee89367e73fb2feb05fc01c004fa (diff)
downloadllvm-a01523ea9939ba360ddca94786134b91189ce42f.tar.gz
[libc] improve error message for unsupported target platforms
Reviewed By: michaelrj Differential Revision: https://reviews.llvm.org/D116888
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index 6e68246d6ceb..95467959af8d 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -89,7 +89,7 @@ if(EXISTS "${LIBC_SOURCE_DIR}/config/${LIBC_TARGET_OS}/${LIBC_TARGET_ARCHITECTUR
elseif(EXISTS "${LIBC_SOURCE_DIR}/config/${LIBC_TARGET_OS}/entrypoints.txt")
set(entrypoint_file "${LIBC_SOURCE_DIR}/config/${LIBC_TARGET_OS}/entrypoints.txt")
else()
- message(FATAL_ERROR "entrypoints.txt file for the target platform not found.")
+ message(FATAL_ERROR "entrypoints.txt file for the target platform '${LIBC_TARGET_OS}/${LIBC_TARGET_ARCHITECTURE}' not found.")
endif()
include(${entrypoint_file})