summaryrefslogtreecommitdiff
path: root/libc/CMakeLists.txt
diff options
context:
space:
mode:
authorSiva Chandra Reddy <sivachandra@google.com>2023-02-24 08:27:29 +0000
committerSiva Chandra Reddy <sivachandra@google.com>2023-02-24 19:55:43 +0000
commitbfeef8b794da7510cd410c87ebc81e231c4450b3 (patch)
tree862791214af7e1c7ed42f3bcaa9adb1167965fa2 /libc/CMakeLists.txt
parentffe9ebbfe1b96f5a9b4476f0a73345779c9ac301 (diff)
downloadllvm-bfeef8b794da7510cd410c87ebc81e231c4450b3.tar.gz
[libc] Add a linting target named "libc-lint".
Lint targets for individual entrypoints have also been cleaned up. The target "libc-lint" depends on the individual lint targets. Reviewed By: lntue Differential Revision: https://reviews.llvm.org/D144705
Diffstat (limited to 'libc/CMakeLists.txt')
-rw-r--r--libc/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libc/CMakeLists.txt b/libc/CMakeLists.txt
index ea5fa4f09ec3..743b241ce26a 100644
--- a/libc/CMakeLists.txt
+++ b/libc/CMakeLists.txt
@@ -107,6 +107,7 @@ if(LLVM_LIBC_ENABLE_LINTING)
The path to the clang-tidy binary can be set manually by passing
-DLLVM_LIBC_CLANG_TIDY=<path/to/clang-tidy> to CMake.")
endif()
+ add_custom_target(libc-lint)
else()
message(FATAL_ERROR "
Linting is enabled but 'clang-tidy' is not found!