summaryrefslogtreecommitdiff
path: root/libc/utils/MPFRWrapper/CMakeLists.txt
diff options
context:
space:
mode:
authorSiva Chandra Reddy <sivachandra@google.com>2023-05-16 17:19:10 +0000
committerSiva Chandra Reddy <sivachandra@google.com>2023-05-17 21:13:50 +0000
commit4dc205f016e3dd2eb1182886a77676f24e39e329 (patch)
tree0bdb52a8263f8fd13d5d3f64ce2ca15359e9c0f4 /libc/utils/MPFRWrapper/CMakeLists.txt
parent42987dfa3a85e0cec987b9f07a8ffe61073ddc52 (diff)
downloadllvm-4dc205f016e3dd2eb1182886a77676f24e39e329.tar.gz
[libc] Add a convenience CMake function `add_unittest_framework_library`.
This function is used to add unit test and hermetic test framework libraries. It avoids the duplicated code to add compile options to each every test framework libraries. Reviewed By: jhuber6 Differential Revision: https://reviews.llvm.org/D150727
Diffstat (limited to 'libc/utils/MPFRWrapper/CMakeLists.txt')
-rw-r--r--libc/utils/MPFRWrapper/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/libc/utils/MPFRWrapper/CMakeLists.txt b/libc/utils/MPFRWrapper/CMakeLists.txt
index 6447d06b7bb5..f1fcf26b6f0b 100644
--- a/libc/utils/MPFRWrapper/CMakeLists.txt
+++ b/libc/utils/MPFRWrapper/CMakeLists.txt
@@ -12,13 +12,13 @@ if(LIBC_TESTS_CAN_USE_MPFR)
libc.src.__support.CPP.type_traits
libc.src.__support.FPUtil.fp_bits
libc.src.__support.FPUtil.platform_defs
- LibcUnitTest
+ LibcTest.unit
)
if(EXISTS ${LLVM_LIBC_MPFR_INSTALL_PATH})
target_include_directories(libcMPFRWrapper PUBLIC ${LLVM_LIBC_MPFR_INSTALL_PATH}/include)
target_link_directories(libcMPFRWrapper PUBLIC ${LLVM_LIBC_MPFR_INSTALL_PATH}/lib)
endif()
- target_link_libraries(libcMPFRWrapper LibcFPTestHelpers LibcUnitTest mpfr gmp)
+ target_link_libraries(libcMPFRWrapper LibcFPTestHelpers.unit LibcTest.unit mpfr gmp)
elseif(NOT LIBC_TARGET_ARCHITECTURE_IS_GPU)
message(WARNING "Math tests using MPFR will be skipped.")
endif()