summaryrefslogtreecommitdiff
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorJoe Loser <joeloser@fastmail.com>2023-01-09 20:13:44 -0700
committerJoe Loser <joeloser@fastmail.com>2023-01-10 13:07:04 -0700
commit07a341c2e4d9356036d6187788443d5c756c02bc (patch)
tree8a26764874ed706ea393e0417e39c28e8a682630 /libcxx/CMakeLists.txt
parent38791259c1165cedfa313e06dc20e443f1e20634 (diff)
downloadllvm-07a341c2e4d9356036d6187788443d5c756c02bc.tar.gz
[libc++] Remove warning for `LIBCXX_SYSROOT`, `LIBCXX_TARGET_TRIPLE`, and `LIBCXX_GCC_TOOLCHAIN`
Support for these CMake variables has been a warning for a while now. The comment indicates to just remove the warning message entirely as anyone impacted had to have update to new mechanisms in order to use `libc++`. So, remove the warning message. Differential Revision: https://reviews.llvm.org/D141345
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index eb71ae89f9fa..f3b2c10ff4d4 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -269,11 +269,6 @@ if (LIBCXX_BUILD_32_BITS)
message(FATAL_ERROR "LIBCXX_BUILD_32_BITS is not supported anymore when building the runtimes, please specify a full triple instead.")
endif()
-# TODO: Remove this after branching for LLVM 15
-if(LIBCXX_SYSROOT OR LIBCXX_TARGET_TRIPLE OR LIBCXX_GCC_TOOLCHAIN)
- message(WARNING "LIBCXX_SYSROOT, LIBCXX_TARGET_TRIPLE and LIBCXX_GCC_TOOLCHAIN are not supported anymore, please use the native CMake equivalents instead")
-endif()
-
# Feature options -------------------------------------------------------------
option(LIBCXX_ENABLE_EXCEPTIONS "Use exceptions." ON)
option(LIBCXX_ENABLE_RTTI "Use run time type information." ON)