summaryrefslogtreecommitdiff
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolas Klauser <nikolasklauser@berlin.de>2023-04-16 22:31:25 +0200
committerNikolas Klauser <nikolasklauser@berlin.de>2023-04-21 05:31:07 +0200
commit7d98590b3a23645584779a1036d319082f3be7c9 (patch)
tree139f9744beb4f9c843c5c8cd48e39f10aaa1dcff /libcxx/CMakeLists.txt
parent0304aa25e0be5f322a76d16c6b6069eb9e153430 (diff)
downloadllvm-7d98590b3a23645584779a1036d319082f3be7c9.tar.gz
[libc++][PSTL] Remove current integration
We decided to go a different route. To make the switch easier, rip out the old integration first and build on a clean base. Reviewed By: ldionne, #libc, #libc_abi Spies: arichardson, libcxx-commits Differential Revision: https://reviews.llvm.org/D148480
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index cf572af74bd1..2b6f9987c675 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -68,7 +68,6 @@ endif()
option(LIBCXX_ENABLE_FILESYSTEM "Build filesystem as part of the main libc++ library"
${ENABLE_FILESYSTEM_DEFAULT})
option(LIBCXX_INCLUDE_TESTS "Build the libc++ tests." ${LLVM_INCLUDE_TESTS})
-option(LIBCXX_ENABLE_PARALLEL_ALGORITHMS "Enable the parallel algorithms library. This requires the PSTL to be available." OFF)
option(LIBCXX_ENABLE_DEBUG_MODE
"Whether to build libc++ with the debug mode enabled.
By default, this is turned off. Turning it on results in a different ABI (additional