summaryrefslogtreecommitdiff
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorLouis Dionne <ldionne.2@gmail.com>2022-06-30 11:57:52 -0400
committerLouis Dionne <ldionne.2@gmail.com>2022-07-19 10:50:20 -0400
commit8711fcae276a59345506f585a29db8e2b07f8d21 (patch)
treed973a4e0fb66904c3476dcd66bcce0f606bae5e0 /libcxx/CMakeLists.txt
parent7300a651f5f3b43f9fa3a2d9927322b0e061fcb2 (diff)
downloadllvm-8711fcae276a59345506f585a29db8e2b07f8d21.tar.gz
[libc++] Treat incomplete features just like other experimental features
In particular remove the ability to expel incomplete features from the library at configure-time, since this can now be done through the _LIBCPP_ENABLE_EXPERIMENTAL macro. Also, never provide symbols related to incomplete features inside the dylib, instead provide them in c++experimental.a (this changes the symbols list, but not for any configuration that should have shipped). Differential Revision: https://reviews.llvm.org/D128928
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index 0977a7229e5d..b47d02324ef5 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -101,11 +101,6 @@ option(LIBCXX_ENABLE_VENDOR_AVAILABILITY_ANNOTATIONS
to provide compile-time errors when using features unavailable on some version of
the shared library they shipped should turn this on and see `include/__availability`
for more details." OFF)
-option(LIBCXX_ENABLE_INCOMPLETE_FEATURES
- "Whether to enable support for incomplete library features. Incomplete features
- are new library features under development. These features don't guarantee
- ABI stability nor the quality of completed library features. Vendors
- shipping the library may want to disable this option." ON)
if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
set(LIBCXX_DEFAULT_TEST_CONFIG "llvm-libc++-shared-gcc.cfg.in")
@@ -866,10 +861,6 @@ if (LIBCXX_ENABLE_ASSERTIONS)
else()
config_define(0 _LIBCPP_ENABLE_ASSERTIONS_DEFAULT)
endif()
-# Incomplete features get their own specific disabling flags. This makes it
-# easier to grep for target specific flags once the feature is complete.
-config_define_if_not(LIBCXX_ENABLE_INCOMPLETE_FEATURES _LIBCPP_HAS_NO_INCOMPLETE_FORMAT)
-config_define_if_not(LIBCXX_ENABLE_INCOMPLETE_FEATURES _LIBCPP_HAS_NO_INCOMPLETE_RANGES)
if (LIBCXX_ABI_DEFINES)
set(abi_defines)