summaryrefslogtreecommitdiff
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorMark de Wever <koraq@xs4all.nl>2023-05-07 20:40:56 +0200
committerMark de Wever <koraq@xs4all.nl>2023-05-16 20:31:44 +0200
commitdc95245e69a1c1098a744a2c3af83ca48d9ba495 (patch)
treec36fec89d8fd75b3822551348c9fa192daee2750 /libcxx/CMakeLists.txt
parent391b51b18f37dd2a130de12167f8b4416eb3210e (diff)
downloadllvm-dc95245e69a1c1098a744a2c3af83ca48d9ba495.tar.gz
[libc++][format] Removes format sources.
The source file is used to anchor the destructor of format_error. When format is moved from experimental to stable this code would move to the dylib. One issue with code in the dylib is that it can't be used in constexpr context. There is a proposal to make format work during constant evaluation P2758 Emitting messages at compile time This paper has initially been received favourable by EWG. Therefore move the code to the header. This also avoids possible availability issues on Mac back deployment targets. Note it is expected that format will no longer be experimental with the next LLVM release. Reviewed By: ldionne, #libc Differential Revision: https://reviews.llvm.org/D150073
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index a003d1e98048..6e9182390247 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -763,14 +763,6 @@ function(cxx_add_windows_flags target)
# Use the ISO conforming behaviour for conversion
# in printf, scanf.
_CRT_STDIO_ISO_WIDE_SPECIFIERS)
- # Clang-cl shared builds don't support the experimental library.
- # To avoid linker errors the format_error destructor is inlined for the
- # dylib. Users can never use format in this mode.
- # TODO FMT Remove when format becomes mainline.
- if (LIBCXX_ENABLE_SHARED)
- target_compile_definitions(${target} PRIVATE
- _LIBCPP_INLINE_FORMAT_ERROR_DTOR)
- endif()
endif()
endfunction()