summaryrefslogtreecommitdiff
path: root/libcxxabi/CMakeLists.txt
diff options
context:
space:
mode:
authorLouis Dionne <ldionne.2@gmail.com>2022-08-23 09:48:36 -0400
committerLouis Dionne <ldionne.2@gmail.com>2022-08-23 09:58:30 -0400
commit342e0ebd0b7409c8808a90cf38dd45ec7dc57671 (patch)
treec836e7bd3cd5113da71861b2a5d5e7366516680b /libcxxabi/CMakeLists.txt
parent7e24354c8ba767be65965566a9dd258703ec86c9 (diff)
downloadllvm-342e0ebd0b7409c8808a90cf38dd45ec7dc57671.tar.gz
Revert the removal of LLVM_ENABLE_PROJECTS for libc++ and libc++abi
This commit reverts the following commits: - 952f90b72b3546d6b6b038d410f07ce520c59b48 - e6a0800532bb409f6d1c62f3698bdd6994a877dc (D132298) - 176db3b3ab25ff8a9b2405f50ef5a8bd9304a6d5 (D132324) These commits caused CI instability and need to be reverted in order to figure things out again. See the discussion in https://llvm.org/D132324 for more information.
Diffstat (limited to 'libcxxabi/CMakeLists.txt')
-rw-r--r--libcxxabi/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index 9064afbe890f..b8326d08d23a 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -131,17 +131,10 @@ if (NOT LIBCXXABI_ENABLE_SHARED AND NOT LIBCXXABI_ENABLE_STATIC)
message(FATAL_ERROR "libc++abi must be built as either a shared or static library.")
endif()
+# TODO: Remove this, which shouldn't be necessary since we know we're being built
+# side-by-side with libc++.
set(LIBCXXABI_LIBCXX_INCLUDES "" CACHE PATH
"Specify path to libc++ includes.")
-if (NOT libcxx IN_LIST LLVM_ENABLE_RUNTIMES)
- if (NOT IS_DIRECTORY ${LIBCXXABI_LIBCXX_INCLUDES})
- message(FATAL_ERROR
- "LIBCXXABI_LIBCXX_INCLUDES=${LIBCXXABI_LIBCXX_INCLUDES} is not a valid directory. "
- "Please provide the path to where the libc++ headers have been installed.")
- endif()
- add_library(cxx-headers INTERFACE)
- target_include_directories(cxx-headers INTERFACE "${LIBCXXABI_LIBCXX_INCLUDES}")
-endif()
set(LIBCXXABI_HERMETIC_STATIC_LIBRARY_DEFAULT OFF)
if (WIN32)