summaryrefslogtreecommitdiff
path: root/libcxxabi/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2022-01-15 07:35:02 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2022-01-15 07:35:02 +0000
commit6e52bfe09d3ab3ae6c43c079d06ebeb7bb241dec (patch)
tree03d6da8f8f48e0bd4f4e690d3ab1f1d8145c89b8 /libcxxabi/CMakeLists.txt
parent26bb1b1dab8bc0646073e762a9f75f2dbcd18857 (diff)
downloadllvm-6e52bfe09d3ab3ae6c43c079d06ebeb7bb241dec.tar.gz
Revert "[cmake] Use `GNUInstallDirs` to support custom installation dirs."
Sorry for the disruption, I will try again later. This reverts commit efeb50197091b2ade24c00b9d55814bc433a7fd1.
Diffstat (limited to 'libcxxabi/CMakeLists.txt')
-rw-r--r--libcxxabi/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index 6b3bcef2851d..b73804390ba2 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -10,8 +10,6 @@ endif()
cmake_minimum_required(VERSION 3.13.4)
-include(GNUInstallDirs)
-
set(LLVM_COMMON_CMAKE_UTILS "${CMAKE_CURRENT_SOURCE_DIR}/../cmake")
# Add path for custom modules
@@ -212,7 +210,7 @@ set(CMAKE_MODULE_PATH
${CMAKE_MODULE_PATH}
)
-set(LIBCXXABI_INSTALL_RUNTIME_DIR "${CMAKE_INSTALL_BINDIR}" CACHE PATH
+set(LIBCXXABI_INSTALL_RUNTIME_DIR bin CACHE PATH
"Path where built libc++abi runtime libraries should be installed.")
if(LLVM_ENABLE_PER_TARGET_RUNTIME_DIR AND NOT APPLE)