summaryrefslogtreecommitdiff
path: root/libcxxabi/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@google.com>2022-03-10 11:47:09 +0200
committerMartin Storsjö <martin@martin.st>2022-04-24 13:06:36 +0300
commitb3df14b6c98702ce50401fd039852787373e4676 (patch)
treeabc180c46d6de2e21bf95e567b61678f35f111f7 /libcxxabi/CMakeLists.txt
parent2fc67af487aa3c2915797a6f2abd4c06e6c1eb08 (diff)
downloadllvm-b3df14b6c98702ce50401fd039852787373e4676.tar.gz
[runtimes] [CMake] Unify variable names
Avoid repeating CMake checks across runtimes by unifying names of variables used for results to leverage CMake caching. Differential Revision: https://reviews.llvm.org/D110005
Diffstat (limited to 'libcxxabi/CMakeLists.txt')
-rw-r--r--libcxxabi/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index a7d6d1902158..8d583df2ef78 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -276,7 +276,7 @@ endif()
# Configure compiler. Must happen after setting the target flags.
include(config-ix)
-if (LIBCXXABI_HAS_NOSTDINCXX_FLAG)
+if (CXX_SUPPORTS_NOSTDINCXX_FLAG)
list(APPEND LIBCXXABI_COMPILE_FLAGS -nostdinc++)
# cmake 3.14 and above remove system include paths that are explicitly
# passed on the command line. We build with -nostdinc++ and explicitly add
@@ -497,7 +497,7 @@ if (LIBCXXABI_BAREMETAL)
add_definitions(-DLIBCXXABI_BAREMETAL)
endif()
-if (LIBCXXABI_HAS_COMMENT_LIB_PRAGMA)
+if (C_SUPPORTS_COMMENT_LIB_PRAGMA)
if (LIBCXXABI_HAS_PTHREAD_LIB)
add_definitions(-D_LIBCXXABI_LINK_PTHREAD_LIB)
endif()