summaryrefslogtreecommitdiff
path: root/libunwind/CMakeLists.txt
diff options
context:
space:
mode:
authorLouis Dionne <ldionne.2@gmail.com>2022-02-15 08:18:38 -0500
committerLouis Dionne <ldionne.2@gmail.com>2022-02-16 09:44:08 -0500
commit641a141da1f22de319e891bdfd61e614632b39f0 (patch)
tree5f933b0b98eea452b1952ce5805a629125c24bd8 /libunwind/CMakeLists.txt
parentc5fb05f663f2ac0cbedb318d03b91d44900ab9de (diff)
downloadllvm-641a141da1f22de319e891bdfd61e614632b39f0.tar.gz
[runtimes] Deprecate FOO_SYSROOT & friends
As suggested in https://reviews.llvm.org/D112155. Differential Revision: https://reviews.llvm.org/D119836
Diffstat (limited to 'libunwind/CMakeLists.txt')
-rw-r--r--libunwind/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
index 6e39bdedc0c2..7ab4a7b2f5b8 100644
--- a/libunwind/CMakeLists.txt
+++ b/libunwind/CMakeLists.txt
@@ -110,6 +110,16 @@ set(LIBUNWIND_TEST_LINKER_FLAGS "" CACHE STRING
set(LIBUNWIND_TEST_COMPILER_FLAGS "" CACHE STRING
"Additional compiler flags for test programs.")
+if(NOT CMAKE_SYSROOT AND LIBUNWIND_SYSROOT)
+ message(WARNING "LIBUNWIND_SYSROOT is deprecated, please use CMAKE_SYSROOT instead")
+endif()
+if(NOT CMAKE_CXX_COMPILER_TARGET AND LIBUNWIND_TARGET_TRIPLE)
+ message(WARNING "LIBUNWIND_TARGET_TRIPLE is deprecated, please use CMAKE_CXX_COMPILER_TARGET instead")
+endif()
+if(NOT CMAKE_CXX_COMPILER_EXTERNAL_TOOLCHAIN AND LIBUNWIND_GCC_TOOLCHAIN)
+ message(WARNING "LIBUNWIND_GCC_TOOLCHAIN is deprecated, please use CMAKE_CXX_COMPILER_EXTERNAL_TOOLCHAIN instead")
+endif()
+
if (LIBUNWIND_ENABLE_SHARED)
set(LIBUNWIND_DEFAULT_TEST_CONFIG "llvm-libunwind-shared.cfg.in")
else()