summaryrefslogtreecommitdiff
path: root/libunwind/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2022-01-16 05:48:30 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2022-01-16 05:48:30 +0000
commitda77db58d7629a3bfea1a0053aa9c29764b0bc2b (patch)
treee295b677ba30783720a7771f6b090b1f2501fa59 /libunwind/CMakeLists.txt
parent4a678f8072004eff9214c1a4e1836a14abb69535 (diff)
downloadllvm-da77db58d7629a3bfea1a0053aa9c29764b0bc2b.tar.gz
Revert "[cmake] Use `GNUInstallDirs` to support custom installation dirs."
https://lab.llvm.org/buildbot/#/builders/46/builds/21146 Still have this odd error, not sure how to reproduce, so I will just try breaking up my patch. This reverts commit 4a678f8072004eff9214c1a4e1836a14abb69535.
Diffstat (limited to 'libunwind/CMakeLists.txt')
-rw-r--r--libunwind/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
index 340a103a4abe..33741aea8f77 100644
--- a/libunwind/CMakeLists.txt
+++ b/libunwind/CMakeLists.txt
@@ -8,8 +8,6 @@ endif()
cmake_minimum_required(VERSION 3.13.4)
-include(GNUInstallDirs)
-
set(LLVM_COMMON_CMAKE_UTILS "${CMAKE_CURRENT_SOURCE_DIR}/../cmake")
# Add path for custom modules
@@ -139,9 +137,9 @@ set(CMAKE_MODULE_PATH
"${CMAKE_CURRENT_SOURCE_DIR}/cmake"
${CMAKE_MODULE_PATH})
-set(LIBUNWIND_INSTALL_INCLUDE_DIR "${CMAKE_INSTALL_INCLUDEDIR}" CACHE PATH
+set(LIBUNWIND_INSTALL_INCLUDE_DIR include CACHE PATH
"Path where built libunwind headers should be installed.")
-set(LIBUNWIND_INSTALL_RUNTIME_DIR "${CMAKE_INSTALL_BINDIR}" CACHE PATH
+set(LIBUNWIND_INSTALL_RUNTIME_DIR bin CACHE PATH
"Path where built libunwind runtime libraries should be installed.")
if(LLVM_ENABLE_PER_TARGET_RUNTIME_DIR AND NOT APPLE)