summaryrefslogtreecommitdiff
path: root/libunwind/CMakeLists.txt
diff options
context:
space:
mode:
authorLouis Dionne <ldionne.2@gmail.com>2022-10-11 09:19:55 -0400
committerLouis Dionne <ldionne.2@gmail.com>2022-10-11 15:18:22 -0400
commitf8409af354c1398ebf4ece67a315c94ba19714b5 (patch)
tree1d47d25b7755105302bfc2df8821b0ecd4bfa338 /libunwind/CMakeLists.txt
parentc2494635f47d94ca1c596fe5e0983295aba81853 (diff)
downloadllvm-f8409af354c1398ebf4ece67a315c94ba19714b5.tar.gz
[libunwind] Install the headers by default
Just like we install libc++ and libc++abi headers by default when we install the library, it makes sense to install the libunwind headers by default when we build libunwind. In the current state of things, there is an increased risk that folks are using older (previously installed) libunwind headers along with a recent libunwind dylib, which is not ideal. Differential Revision: https://reviews.llvm.org/D135663
Diffstat (limited to 'libunwind/CMakeLists.txt')
-rw-r--r--libunwind/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
index ca6a43da7487..210ebb8a33f7 100644
--- a/libunwind/CMakeLists.txt
+++ b/libunwind/CMakeLists.txt
@@ -49,7 +49,7 @@ option(LIBUNWIND_INCLUDE_TESTS "Build the libunwind tests." ${LLVM_INCLUDE_TESTS
option(LIBUNWIND_IS_BAREMETAL "Build libunwind for baremetal targets." OFF)
option(LIBUNWIND_USE_FRAME_HEADER_CACHE "Cache frame headers for unwinding. Requires locking dl_iterate_phdr." OFF)
option(LIBUNWIND_REMEMBER_HEAP_ALLOC "Use heap instead of the stack for .cfi_remember_state." OFF)
-option(LIBUNWIND_INSTALL_HEADERS "Install the libunwind headers." OFF)
+option(LIBUNWIND_INSTALL_HEADERS "Install the libunwind headers." ON)
set(LIBUNWIND_LIBDIR_SUFFIX "${LLVM_LIBDIR_SUFFIX}" CACHE STRING
"Define suffix of library directory name (32/64)")