summaryrefslogtreecommitdiff
path: root/lld/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@google.com>2020-07-23 15:12:42 -0700
committerPetr Hosek <phosek@google.com>2020-07-23 15:12:42 -0700
commit38c71b7c85cac4c8de39329ff3ed682e63f61525 (patch)
treed808068f727537568ca5a35a82562b721083e111 /lld/CMakeLists.txt
parentb83417aa7e26ca76c433ec5befdecd5c571408a6 (diff)
downloadllvm-38c71b7c85cac4c8de39329ff3ed682e63f61525.tar.gz
Revert "[CMake] Simplify CMake handling for zlib"
This reverts commit 1d09ecf36175f7910ffedd6d497c07b5c74c22fb since it breaks sanitizer bots.
Diffstat (limited to 'lld/CMakeLists.txt')
-rw-r--r--lld/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
index bcfc2c6270b3..e9bd1bd29c5c 100644
--- a/lld/CMakeLists.txt
+++ b/lld/CMakeLists.txt
@@ -51,10 +51,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
set(LLVM_RUNTIME_OUTPUT_INTDIR ${CMAKE_BINARY_DIR}/${CMAKE_CFG_INTDIR}/bin)
find_program(LLVM_TABLEGEN_EXE "llvm-tblgen" ${LLVM_TOOLS_BINARY_DIR} NO_DEFAULT_PATH)
- if(LLVM_ENABLE_ZLIB)
- find_package(ZLIB)
- endif()
-
include(AddLLVM)
include(TableGen)
include(HandleLLVMOptions)