summaryrefslogtreecommitdiff
path: root/lld/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@google.com>2020-07-27 11:55:52 -0700
committerPetr Hosek <phosek@google.com>2020-07-27 17:13:55 -0700
commit64d99cc6abed78c00a2a7863b02ce54911a5264f (patch)
treeb31f8336013e9b5f9e8c83bff82c76440f042126 /lld/CMakeLists.txt
parentf250eb37cd4fabcc9f222ca2da80b62d110d9fff (diff)
downloadllvm-64d99cc6abed78c00a2a7863b02ce54911a5264f.tar.gz
[CMake] Move find_package(ZLIB) to LLVMConfig
This way, downstream projects don't have to invoke find_package(ZLIB) reducing the amount of boilerplate. Differential Revision: https://reviews.llvm.org/D84691
Diffstat (limited to 'lld/CMakeLists.txt')
-rw-r--r--lld/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
index bcfc2c6270b3..e9bd1bd29c5c 100644
--- a/lld/CMakeLists.txt
+++ b/lld/CMakeLists.txt
@@ -51,10 +51,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
set(LLVM_RUNTIME_OUTPUT_INTDIR ${CMAKE_BINARY_DIR}/${CMAKE_CFG_INTDIR}/bin)
find_program(LLVM_TABLEGEN_EXE "llvm-tblgen" ${LLVM_TOOLS_BINARY_DIR} NO_DEFAULT_PATH)
- if(LLVM_ENABLE_ZLIB)
- find_package(ZLIB)
- endif()
-
include(AddLLVM)
include(TableGen)
include(HandleLLVMOptions)