summaryrefslogtreecommitdiff
path: root/lld/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-24 06:31:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-27 13:46:56 +0200
commit88d7508dc479210f07abccb17f0194b66264b125 (patch)
tree59746b6b1e9baa88cc12665229414f63c381536d /lld/CMakeLists.txt
parent7ab21cdc208491c5f935b9fbc18c3436a6e14c1f (diff)
downloadllvm-88d7508dc479210f07abccb17f0194b66264b125.tar.gz
Harmonize cmake_policy() across standalone builds of all projects
Move `cmake_policy()` settings from `llvm/CMakeLists.txt` into a shared `cmake/modules/CMakePolicy.cmake`. Include it from all relevant projects that support standalone builds, in order to ensure that the policies are consistently set whether they are built in-tree or stand-alone. Differential Revision: https://reviews.llvm.org/D136572
Diffstat (limited to 'lld/CMakeLists.txt')
-rw-r--r--lld/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
index be4ea8540750..964bc3fd8b17 100644
--- a/lld/CMakeLists.txt
+++ b/lld/CMakeLists.txt
@@ -1,4 +1,6 @@
cmake_minimum_required(VERSION 3.13.4)
+include(${CMAKE_CURRENT_SOURCE_DIR}/../cmake/Modules/CMakePolicy.cmake
+ NO_POLICY_SCOPE)
# If we are not building as a part of LLVM, build LLD as an
# standalone project, using LLVM as an external library: