summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorMark de Wever <koraq@xs4all.nl>2023-04-15 13:12:04 +0200
committerMark de Wever <koraq@xs4all.nl>2023-04-15 13:12:04 +0200
commit1ef4c3c859728008cf707cad8d67f45ae5070ae1 (patch)
tree07854b80441bd132812f864390260ade4f0278a8 /lldb/CMakeLists.txt
parentb251879376735da180c8328827211924b2d9937e (diff)
downloadllvm-1ef4c3c859728008cf707cad8d67f45ae5070ae1.tar.gz
Revert "Revert "[CMake] Bumps minimum version to 3.20.0.""
This reverts commit 92523a35a827539db8557bbc3ecab7f9ea3f6ade. Reland to see whether CIs are updated.
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 20d584c48bad..9ae6722295ac 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.13.4)
+cmake_minimum_required(VERSION 3.20.0)
if(NOT DEFINED LLVM_COMMON_CMAKE_UTILS)
set(LLVM_COMMON_CMAKE_UTILS ${CMAKE_CURRENT_SOURCE_DIR}/../cmake)
@@ -19,13 +19,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
project(lldb)
set(LLDB_BUILT_STANDALONE TRUE)
set(LLVM_INCLUDE_TESTS ON CACHE INTERNAL "")
- if ("${CMAKE_VERSION}" VERSION_LESS "3.20.0")
- message(WARNING
- "Your CMake version is ${CMAKE_VERSION}. Starting with LLVM 17.0.0, the "
- "minimum version of CMake required to build LLVM will become 3.20.0, and "
- "using an older CMake will become an error. Please upgrade your CMake to "
- "at least 3.20.0 now to avoid issues in the future!")
- endif()
endif()
# Must go below project(..)