summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2019-12-22 13:57:46 -0800
committerSaleem Abdulrasool <compnerd@compnerd.org>2019-12-22 13:57:46 -0800
commit2046d72e91670114625c87e122db6e013ba089d5 (patch)
tree36230b18f453b6556800bd7b6c51402038acbe20 /lldb/CMakeLists.txt
parent891e25b02d760d0de18c7d46947913b3166047e7 (diff)
downloadllvm-2046d72e91670114625c87e122db6e013ba089d5.tar.gz
build: improve python checks for Windows
Require a newer CMake on Windows to use the Python3 support that is packaged in CMake. This version is able to check both 32-bit and 64-bit versions and will setup everything properly without the user needing to specify PYTHON_HOME. This enables building lldb's python bindings on Windows under Azure's CI again.
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index ff3d8ae70747..6170ab625c54 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -1,4 +1,7 @@
cmake_minimum_required(VERSION 3.4.3)
+if(CMAKE_SYSTEM_NAME STREQUAL Windows)
+ cmake_minimum_required(VERSION 3.13)
+endif()
if(POLICY CMP0075)
cmake_policy(SET CMP0075 NEW)