summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2019-12-13 10:37:33 -0800
committerJonas Devlieghere <jonas@devlieghere.com>2019-12-13 13:41:11 -0800
commit4e26cf2cfb2b140a33ec236153cb2f23b5c44127 (patch)
tree466e768fef375dd038474f91abc4eb255dca93ec /lldb/CMakeLists.txt
parent9cb7a1be2a430a50fb5644b3f48d4a1544034fb9 (diff)
downloadllvm-4e26cf2cfb2b140a33ec236153cb2f23b5c44127.tar.gz
[lldb/CMake] Rename LLDB_DISABLE_PYTHON to LLDB_ENABLE_PYTHON
This matches the naming scheme used by LLVM and all the other optional dependencies in LLDB. Differential revision: https://reviews.llvm.org/D71482
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index e66fa49a5114..3747c9896525 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -40,7 +40,7 @@ if (WIN32)
add_definitions(-D_ENABLE_EXTENDED_ALIGNED_STORAGE)
endif()
-if (NOT LLDB_DISABLE_PYTHON)
+if (LLDB_ENABLE_PYTHON)
execute_process(
COMMAND ${PYTHON_EXECUTABLE}
-c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(True, False, ''))"
@@ -91,7 +91,7 @@ if(LLDB_INCLUDE_TESTS)
add_subdirectory(utils/lldb-dotest)
endif()
-if (NOT LLDB_DISABLE_PYTHON)
+if (LLDB_ENABLE_PYTHON)
get_target_property(lldb_scripts_dir swig_wrapper BINARY_DIR)
if(LLDB_BUILD_FRAMEWORK)