summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Langford <alangford@apple.com>2022-11-17 13:46:40 -0800
committerAlex Langford <alangford@apple.com>2022-11-18 09:05:08 -0800
commit58d38b3ff8c3c4dd816d2047acf65fa97c0b6fb8 (patch)
treef9abcf7ddde49817d6837cc8da2595759e3209c0 /lldb/CMakeLists.txt
parent0f3e72e86c8c7c6bf0ec24bf1e2acd74b4123e7b (diff)
downloadllvm-58d38b3ff8c3c4dd816d2047acf65fa97c0b6fb8.tar.gz
[lldb] Restore default setting of LLDB_INCLUDE_TESTS in standalone builds
In 52f39853abd46495a6d636c4b035e1b92cf4b833 the option LLDB_INCLUDE_TESTS was moved above the inclusion of LLDBStandalone. This isn't a problem per-se, but it changes the default value of LLDB_INCLUDE_TESTS in standalone builds. LLDBStandalone explicitly sets LLVM_INCLUDE_TESTS to true, indicating that for standalone builds this is considered the default behavior. This patch restores said default behavior. Differential Revision: https://reviews.llvm.org/D138237
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 6f314634d23b..110c7b09326d 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -18,6 +18,7 @@ set(CMAKE_MODULE_PATH
if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
project(lldb)
set(LLDB_BUILT_STANDALONE TRUE)
+ set(LLVM_INCLUDE_TESTS ON CACHE INTERNAL "")
endif()
# Must go below project(..)