summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2020-01-09 07:57:59 -0800
committerJonas Devlieghere <jonas@devlieghere.com>2020-01-09 08:44:34 -0800
commit6498aff249a1c3c6bad33137df3b90e2973722d6 (patch)
tree9574b97e6ca0a04d4895e4fba7fd164603c2ad47 /lldb/CMakeLists.txt
parent241f335b268dc19a0dfb85686a7c82fb339421a8 (diff)
downloadllvm-6498aff249a1c3c6bad33137df3b90e2973722d6.tar.gz
[lldb/Bindings] Move bindings into their own subdirectory
All the code required to generate the language bindings for Python and Lua lives under scripts, even though the majority of this code aren't scripts at all, and surrounded by scripts that are totally unrelated. I've reorganized these files and moved everything related to the language bindings into a new top-level directory named bindings. This makes the corresponding files self contained and much more discoverable. Differential revision: https://reviews.llvm.org/D72437
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 6170ab625c54..573b8556989e 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -56,7 +56,7 @@ if (LLDB_ENABLE_PYTHON)
endif ()
if (LLDB_ENABLE_PYTHON OR LLDB_ENABLE_LUA)
- add_subdirectory(scripts)
+ add_subdirectory(bindings)
endif ()
# We need the headers generated by instrinsics_gen before we can compile
@@ -97,7 +97,7 @@ if(LLDB_INCLUDE_TESTS)
endif()
if (LLDB_ENABLE_PYTHON)
- get_target_property(lldb_scripts_dir swig_wrapper BINARY_DIR)
+ get_target_property(lldb_bindings_dir swig_wrapper BINARY_DIR)
if(LLDB_BUILD_FRAMEWORK)
set(lldb_python_build_path "${LLDB_FRAMEWORK_ABSOLUTE_BUILD_DIR}/LLDB.framework/Resources/Python/lldb")
@@ -109,7 +109,7 @@ if (LLDB_ENABLE_PYTHON)
# to liblldb.so for the Python API(hardlink on Windows).
add_custom_target(finish_swig ALL VERBATIM
COMMAND ${CMAKE_COMMAND} -E make_directory ${lldb_python_build_path}
- DEPENDS ${lldb_scripts_dir}/lldb.py
+ DEPENDS ${lldb_bindings_dir}/lldb.py
COMMENT "Python script sym-linking LLDB Python API")
if(NOT LLDB_USE_SYSTEM_SIX)
@@ -121,7 +121,7 @@ if (LLDB_ENABLE_PYTHON)
add_custom_command(TARGET finish_swig POST_BUILD VERBATIM
COMMAND ${CMAKE_COMMAND} -E copy
- "${lldb_scripts_dir}/lldb.py"
+ "${lldb_bindings_dir}/lldb.py"
"${lldb_python_build_path}/__init__.py")
function(create_python_package pkg_dir)
@@ -131,7 +131,7 @@ if (LLDB_ENABLE_PYTHON)
endif()
if(NOT ARG_NOINIT)
set(init_cmd COMMAND ${PYTHON_EXECUTABLE}
- "${LLDB_SOURCE_DIR}/scripts/Python/createPythonInit.py"
+ "${LLDB_SOURCE_DIR}/bindings/python/createPythonInit.py"
"${pkg_dir}" ${ARG_FILES})
endif()
add_custom_command(TARGET finish_swig POST_BUILD VERBATIM