summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2020-08-17 08:47:52 -0700
committerJonas Devlieghere <jonas@devlieghere.com>2020-08-17 08:47:52 -0700
commit75966ee241a2f1b7712caa1bbe66560347b23359 (patch)
tree0f679f3b7bac3033b866a04d40742a84559db8f0 /lldb/CMakeLists.txt
parent32ebdc70f3af478f4f6a9c75b4bc47a453b1b933 (diff)
downloadllvm-75966ee241a2f1b7712caa1bbe66560347b23359.tar.gz
[lldb] Get rid of helper CMake variables for Python
This patch is a big sed to rename the following variables: s/PYTHON_LIBRARIES/Python3_LIBRARIES/g s/PYTHON_INCLUDE_DIRS/Python3_INCLUDE_DIRS/g s/PYTHON_EXECUTABLE/Python3_EXECUTABLE/g s/PYTHON_RPATH/Python3_RPATH/g I've also renamed the CMake module to better express its purpose and for consistency with FindLuaAndSwig. Differential revision: https://reviews.llvm.org/D85976
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index cd3d3c8d7e01..4e417e97c188 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -36,7 +36,7 @@ endif()
if (LLDB_ENABLE_PYTHON)
execute_process(
- COMMAND ${PYTHON_EXECUTABLE}
+ COMMAND ${Python3_EXECUTABLE}
-c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(True, False, ''))"
OUTPUT_VARIABLE LLDB_PYTHON_DEFAULT_RELATIVE_PATH
OUTPUT_STRIP_TRAILING_WHITESPACE)