summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2019-10-15 21:24:37 +0200
committerLuboš Luňák <l.lunak@centrum.cz>2019-11-02 10:22:47 +0100
commit79d8996d73f3bb5709a1eca206a848543340633d (patch)
tree964ab129873f4e7164514c6e3340076dc0e5dab3 /lldb/CMakeLists.txt
parent462a67fadd8bec3fe86bef0b045649f65cffaedd (diff)
downloadllvm-79d8996d73f3bb5709a1eca206a848543340633d.tar.gz
python path should be platform-dependent
Because one of the installed files is the _lldb.so symlink. Differential Revision: https://reviews.llvm.org/D68910
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 511c75d76588..388bcf76e662 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -43,7 +43,7 @@ endif()
if (NOT LLDB_DISABLE_PYTHON)
execute_process(
COMMAND ${PYTHON_EXECUTABLE}
- -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(False, False, ''))"
+ -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(True, False, ''))"
OUTPUT_VARIABLE LLDB_PYTHON_DEFAULT_RELATIVE_PATH
OUTPUT_STRIP_TRAILING_WHITESPACE)