summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2020-03-27 17:48:58 -0700
committerJonas Devlieghere <jonas@devlieghere.com>2020-03-27 17:49:00 -0700
commit823dbb4c748feaae6f20637efd0de159dd156c69 (patch)
tree1d361997544b9e90e601040ebac48e1a447270a2 /lldb/CMakeLists.txt
parenta67f057f6975d2b7e51765e976b8772ffb8fb7e8 (diff)
downloadllvm-823dbb4c748feaae6f20637efd0de159dd156c69.tar.gz
[lldb/CMake] Only CMAKE_CFG_INTDIR if it's not '.'
Thanks to Brooks Davis for spotting this and finding a solution.
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 7e8890da0204..bf748020ea40 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -224,8 +224,10 @@ if (LLDB_ENABLE_PYTHON)
else()
set(LLDB_PYTHON_INSTALL_PATH ${LLDB_PYTHON_RELATIVE_PATH})
endif()
- string(REPLACE ${CMAKE_CFG_INTDIR} "\$\{CMAKE_INSTALL_CONFIG_NAME\}" LLDB_PYTHON_INSTALL_PATH ${LLDB_PYTHON_INSTALL_PATH})
- string(REPLACE ${CMAKE_CFG_INTDIR} "\$\{CMAKE_INSTALL_CONFIG_NAME\}" lldb_python_build_path ${lldb_python_build_path})
+ if (NOT CMAKE_CFG_INTDIR STREQUAL ".")
+ string(REPLACE ${CMAKE_CFG_INTDIR} "\$\{CMAKE_INSTALL_CONFIG_NAME\}" LLDB_PYTHON_INSTALL_PATH ${LLDB_PYTHON_INSTALL_PATH})
+ string(REPLACE ${CMAKE_CFG_INTDIR} "\$\{CMAKE_INSTALL_CONFIG_NAME\}" lldb_python_build_path ${lldb_python_build_path})
+ endif()
add_custom_target(lldb-python-scripts)
add_dependencies(lldb-python-scripts finish_swig)
install(DIRECTORY ${lldb_python_build_path}/../