summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Storsjö <martin@martin.st>2019-12-22 10:01:09 +0200
committerMartin Storsjö <martin@martin.st>2019-12-22 10:04:56 +0200
commit9a3fab97468f9555a770707e23a4c424bfd696c2 (patch)
treee06ef54500a7ac7292ca82763a65a13dc4c18f4a /lldb/CMakeLists.txt
parent527b0f8c7448707aa6b8159e6e4707a49f1dcb87 (diff)
downloadllvm-9a3fab97468f9555a770707e23a4c424bfd696c2.tar.gz
[LLDB] Fix building without SWIG
Previously, SWIG was only a hard dependency if python bindings were enabled. Since bf03e17c570171c7a52117fe63ace89d58f328d5, scripts/CMakeLists.txt is included unconditionally, while that file adds the hard dependency on SWIG. Instead, only include that file if either python or lua bindings are enabled.
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 39e12b251623..ff3d8ae70747 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -52,7 +52,9 @@ if (LLDB_ENABLE_PYTHON)
CACHE STRING "Path where Python modules are installed, relative to install prefix")
endif ()
-add_subdirectory(scripts)
+if (LLDB_ENABLE_PYTHON OR LLDB_ENABLE_LUA)
+ add_subdirectory(scripts)
+endif ()
# We need the headers generated by instrinsics_gen before we can compile
# any source file in LLDB as the imported Clang modules might include