summaryrefslogtreecommitdiff
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2019-12-08 15:32:57 -0800
committerJonas Devlieghere <jonas@devlieghere.com>2019-12-21 11:28:41 -0800
commitbf03e17c570171c7a52117fe63ace89d58f328d5 (patch)
tree8361b20a3a9569ef8cf70fed5033e24c414e99c7 /lldb/CMakeLists.txt
parent2203089a60d826e882e2ccfc5cc5d361b4f91078 (diff)
downloadllvm-bf03e17c570171c7a52117fe63ace89d58f328d5.tar.gz
[Lldb/Lua] Generate Lua Bindings
This patch uses SWIG to generate the Lua bindings for the SB API. It covers most of the API, but some methods require a type map similar to Python. Discussion on the mailing list: http://lists.llvm.org/pipermail/lldb-dev/2019-December/015812.html Differential revision: https://reviews.llvm.org/D71235
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 3747c9896525..39e12b251623 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -50,10 +50,10 @@ if (LLDB_ENABLE_PYTHON)
file(TO_CMAKE_PATH ${LLDB_PYTHON_DEFAULT_RELATIVE_PATH} LLDB_PYTHON_DEFAULT_RELATIVE_PATH)
set(LLDB_PYTHON_RELATIVE_PATH ${LLDB_PYTHON_DEFAULT_RELATIVE_PATH}
CACHE STRING "Path where Python modules are installed, relative to install prefix")
-
- add_subdirectory(scripts)
endif ()
+add_subdirectory(scripts)
+
# We need the headers generated by instrinsics_gen before we can compile
# any source file in LLDB as the imported Clang modules might include
# some of these generated headers. This approach is copied from Clang's main