summaryrefslogtreecommitdiff
path: root/llvm/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Stellard <tstellar@redhat.com>2023-03-10 17:22:14 -0800
committerTom Stellard <tstellar@redhat.com>2023-03-10 17:22:33 -0800
commit0807986303f5d498cee32d42c242940d00617ad9 (patch)
tree03d9c9486e933f02c720bbfb50f1ed107c5b55d4 /llvm/CMakeLists.txt
parent7c3c981442b11153ac1a2be678db727ff715253b (diff)
downloadllvm-0807986303f5d498cee32d42c242940d00617ad9.tar.gz
Add install targets for gtest
Stand-alone builds need an installed version of gtest in order to run the unittests. Reviewed By: mgorny, kwk Differential Revision: https://reviews.llvm.org/D137890
Diffstat (limited to 'llvm/CMakeLists.txt')
-rw-r--r--llvm/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
index ba73ebaeaf4a..bd23d6657829 100644
--- a/llvm/CMakeLists.txt
+++ b/llvm/CMakeLists.txt
@@ -720,6 +720,10 @@ option(LLVM_BUILD_TESTS
"Build LLVM unit tests. If OFF, just generate build targets." OFF)
option(LLVM_INCLUDE_TESTS "Generate build targets for the LLVM unit tests." ON)
+option(LLVM_INSTALL_GTEST
+ "Install the llvm gtest library. This should be on if you want to do
+ stand-alone builds of the other projects and run their unit tests." OFF)
+
option(LLVM_BUILD_BENCHMARKS "Add LLVM benchmark targets to the list of default
targets. If OFF, benchmarks still could be built using Benchmarks target." OFF)
option(LLVM_INCLUDE_BENCHMARKS "Generate benchmark targets. If OFF, benchmarks can't be built." ON)