summaryrefslogtreecommitdiff
path: root/llvm/CMakeLists.txt
diff options
context:
space:
mode:
authorVolodymyr Sapsai <vsapsai@apple.com>2023-03-08 20:14:44 -0800
committerVolodymyr Sapsai <vsapsai@apple.com>2023-05-03 13:07:47 -0700
commit24f36a215b4eabd1d0e4abcce0c9277085d88a96 (patch)
tree43a9e7870daed2b8254b142144cb886173398524 /llvm/CMakeLists.txt
parent3aaf0bed1c68f0b0052a569437cbdf489ff68b56 (diff)
downloadllvm-24f36a215b4eabd1d0e4abcce0c9277085d88a96.tar.gz
[Modules] Move modulemaps to header search directories. NFC intended.
In code we use `#include "llvm/Lib/Header.h"` which is located in "llvm/include/llvm/Lib/Header.h", so we use "llvm/include/" as a header search path. We should put modulemaps in the same directory and shouldn't rely on clang to search in immediate subdirectories. rdar://106677321 Differential Revision: https://reviews.llvm.org/D148776
Diffstat (limited to 'llvm/CMakeLists.txt')
-rw-r--r--llvm/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
index bd23d6657829..ce6cd1a52d3a 100644
--- a/llvm/CMakeLists.txt
+++ b/llvm/CMakeLists.txt
@@ -1163,7 +1163,7 @@ add_subdirectory(lib/TableGen)
add_subdirectory(utils/TableGen)
-add_subdirectory(include/llvm)
+add_subdirectory(include)
add_subdirectory(lib)
@@ -1275,14 +1275,14 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
)
if (LLVM_INSTALL_MODULEMAPS)
- install(DIRECTORY include/llvm include/llvm-c
+ install(DIRECTORY include
DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
COMPONENT llvm-headers
FILES_MATCHING
PATTERN "module.modulemap"
)
- install(FILES include/llvm/module.install.modulemap
- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/llvm"
+ install(FILES include/module.install.modulemap
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
COMPONENT llvm-headers
RENAME "module.extern.modulemap"
)