summaryrefslogtreecommitdiff
path: root/llvm/CMakeLists.txt
diff options
context:
space:
mode:
authorWeining Lu <luweining@loongson.cn>2023-01-11 16:35:48 +0800
committerWeining Lu <luweining@loongson.cn>2023-01-11 16:36:02 +0800
commit85865f965d572faf9c275fc08855ae308ef2154b (patch)
tree23ff60bd88ca76baedd3356798cc85e06ab1acd2 /llvm/CMakeLists.txt
parent87bd946138483068ab30ff8a19d4ec344de42f57 (diff)
downloadllvm-85865f965d572faf9c275fc08855ae308ef2154b.tar.gz
Reland "[CMake][LoongArch] Add LoongArch to LLVM_ALL_TARGETS so it is built by default"
This follows the [[ https://discourse.llvm.org/t/rfc-promoting-the-loongarch-backend-from-experimental-to-official/67506/ | RFC ]]. Follow-on commits will add appropriate release notes changes etc. Submit this now and in a minimal form so there is reasonable time before 16.0.0 is branched to resolve any issues arising from e.g. the backend being exposed on different compiler/sanitizer setups. The current builder for LoongArch is on the [[ https://lab.llvm.org/staging/#/builders/236 | staging area ]]. Reviewed By: jyknight, MaskRay, echristo, myhsu, tstellar, arsenm Differential Revision: https://reviews.llvm.org/D141191
Diffstat (limited to 'llvm/CMakeLists.txt')
-rw-r--r--llvm/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
index 8e8cd3e38359..58fc88541573 100644
--- a/llvm/CMakeLists.txt
+++ b/llvm/CMakeLists.txt
@@ -431,6 +431,7 @@ set(LLVM_ALL_TARGETS
BPF
Hexagon
Lanai
+ LoongArch
Mips
MSP430
NVPTX