summaryrefslogtreecommitdiff
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorprotze@itc.rwth-aachen.de <protze@itc.rwth-aachen.de>2019-11-18 01:23:31 +0100
committerprotze@itc.rwth-aachen.de <protze@itc.rwth-aachen.de>2019-11-18 14:45:34 +0100
commit2b8115b10b03013b9f8ae0aa56b0cd6a6a6dd4fd (patch)
tree0432a21c8abc89249de1eae88269a3d88388d68e /openmp/CMakeLists.txt
parentc070a27acc474a2e4a159d8797d4506bcbe71a30 (diff)
downloadllvm-2b8115b10b03013b9f8ae0aa56b0cd6a6a6dd4fd.tar.gz
[OpenMP] Add implementation and tests of Archer tool
The tool provides TSAN annotations for OpenMP synchronization. The tool is activated if no other OMPT tool is loaded. The tool detects whether the application was built with TSan and rejects activation according to the OMPT protocol if there is no TSan-rt. Differential Revision: https://reviews.llvm.org/D45890
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index 597eedcec0b5..e6ab73f88903 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -79,5 +79,17 @@ if (OPENMP_ENABLE_LIBOMPTARGET)
add_subdirectory(libomptarget)
endif()
+set(ENABLE_OMPT_TOOLS ON)
+# Currently tools are not tested well on Windows or MacOS X.
+if (APPLE OR WIN32)
+ set(ENABLE_OMPT_TOOLS OFF)
+endif()
+
+option(OPENMP_ENABLE_OMPT_TOOLS "Enable building ompt based tools for OpenMP."
+ ${ENABLE_OMPT_TOOLS})
+if (OPENMP_ENABLE_OMPT_TOOLS)
+ add_subdirectory(tools)
+endif()
+
# Now that we have seen all testuites, create the check-openmp target.
construct_check_openmp_target()