summaryrefslogtreecommitdiff
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorJohannes Doerfert <johannes@jdoerfert.de>2020-02-11 17:08:48 -0600
committerJohannes Doerfert <johannes@jdoerfert.de>2020-02-11 17:11:54 -0600
commit3ff4e2eee8c39fd4ae13b1df412f0af219fbf382 (patch)
treeeffd86090f010466c42cbed87d2e90d3dfadb7da /openmp/CMakeLists.txt
parentd3a96fc082bef6a15f1ce8aed1849ff4122636dc (diff)
downloadllvm-3ff4e2eee8c39fd4ae13b1df412f0af219fbf382.tar.gz
[OpenMP] Switch default C++ standard to C++ 14
Reviewed By: JonChesterfield Differential Revision: https://reviews.llvm.org/D74258
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index 9825183a0dd7..7007611301f0 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -62,7 +62,7 @@ set(ENABLE_LIBOMPTARGET ON)
# Currently libomptarget cannot be compiled on Windows or MacOS X.
# Since the device plugins are only supported on Linux anyway,
# there is no point in trying to compile libomptarget on other OSes.
-if (APPLE OR WIN32 OR NOT OPENMP_HAVE_STD_CPP11_FLAG)
+if (APPLE OR WIN32 OR NOT OPENMP_HAVE_STD_CPP14_FLAG)
set(ENABLE_LIBOMPTARGET OFF)
endif()
@@ -72,8 +72,8 @@ if (OPENMP_ENABLE_LIBOMPTARGET)
# Check that the library can actually be built.
if (APPLE OR WIN32)
message(FATAL_ERROR "libomptarget cannot be built on Windows and MacOS X!")
- elseif (NOT OPENMP_HAVE_STD_CPP11_FLAG)
- message(FATAL_ERROR "Host compiler must support C++11 to build libomptarget!")
+ elseif (NOT OPENMP_HAVE_STD_CPP14_FLAG)
+ message(FATAL_ERROR "Host compiler must support C++14 to build libomptarget!")
endif()
add_subdirectory(libomptarget)