summaryrefslogtreecommitdiff
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorJoseph Huber <jhuber6@vols.utk.edu>2022-11-14 08:11:33 -0600
committerJoseph Huber <jhuber6@vols.utk.edu>2022-11-14 08:21:46 -0600
commit87760910a3111948fa56f2717fbf53e536893b2d (patch)
treefdb8b6c56f6aa4fcf872dbd67f58bf20a822bd7a /openmp/CMakeLists.txt
parent5c67cf0a7fdc00c9b9c55578b770e768f5618bed (diff)
downloadllvm-87760910a3111948fa56f2717fbf53e536893b2d.tar.gz
[OpenMP] Fix installation to old resource dir
Summary: The changes in D125860 renamed the old resource directory to only use the major version. This was not updated for the OpenMP project, causing OpenMP resources to still be installed in the old `major.minor.rev` folder. This lead to problems including the header files. fixes #58966
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index 502a06ed916e..7f6ea8e920a9 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -79,7 +79,7 @@ option(OPENMP_ENABLE_LIBOMP_PROFILING "Enable time profiling for libomp." OFF)
if(${OPENMP_STANDALONE_BUILD})
set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}")
else()
- string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
+ string(REGEX MATCH "[0-9]+" CLANG_VERSION ${PACKAGE_VERSION})
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
endif()