summaryrefslogtreecommitdiff
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorBran Hagger <brhagger@microsoft.com>2021-11-11 13:08:25 -0600
committerJonathan Peyton <jonathan.l.peyton@intel.com>2021-11-11 13:11:56 -0600
commit9f15cacc2ecd2eb1dda8ca0b8ae984286fb4135f (patch)
treed51b54c193c83bc502f8e3ee5e9a745a5de3d04f /openmp/CMakeLists.txt
parent9deab60ae710f8c4cc810cd680edfb64c803f42d (diff)
downloadllvm-9f15cacc2ecd2eb1dda8ca0b8ae984286fb4135f.tar.gz
[OpenMP] Allow building libomp using Microsoft Visual C++ naming scheme
Differential Revision: https://reviews.llvm.org/D110354
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index b48c5d4a8e9c..c164f4768198 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -97,6 +97,7 @@ if (OPENMP_ENABLE_OMPT_TOOLS)
add_subdirectory(tools)
endif()
+option(OPENMP_MSVC_NAME_SCHEME "Build dll with MSVC naming scheme." OFF)
# Build documentation
add_subdirectory(docs)