summaryrefslogtreecommitdiff
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorMark de Wever <koraq@xs4all.nl>2023-03-18 13:33:42 +0100
committerMark de Wever <koraq@xs4all.nl>2023-03-18 13:33:42 +0100
commita72165e5df59032cdd54dcb18155f2630d73abd1 (patch)
treeebf7620f30cf1e5765a4ba6f71e5286196ffb550 /openmp/CMakeLists.txt
parent113f0190dd386d93b42d781b975aa2cca5c88914 (diff)
downloadllvm-a72165e5df59032cdd54dcb18155f2630d73abd1.tar.gz
Reland "[CMake] Bumps minimum version to 3.20.0."
This reverts commit 92523a35a827539db8557bbc3ecab7f9ea3f6ade. Test whether all CI runners are updated.
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index a87ea2fb57c5..50246b663289 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.13.4)
+cmake_minimum_required(VERSION 3.20.0)
set(LLVM_COMMON_CMAKE_UTILS ${CMAKE_CURRENT_SOURCE_DIR}/../cmake)
@@ -12,13 +12,6 @@ list(INSERT CMAKE_MODULE_PATH 0
if (OPENMP_STANDALONE_BUILD OR "${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
set(OPENMP_STANDALONE_BUILD TRUE)
project(openmp C CXX)
- if ("${CMAKE_VERSION}" VERSION_LESS "3.20.0")
- message(WARNING
- "Your CMake version is ${CMAKE_VERSION}. Starting with LLVM 17.0.0, the "
- "minimum version of CMake required to build LLVM will become 3.20.0, and "
- "using an older CMake will become an error. Please upgrade your CMake to "
- "at least 3.20.0 now to avoid issues in the future!")
- endif()
endif()
# Must go below project(..)