summaryrefslogtreecommitdiff
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Hahnfeld <hahnjo@hahnjo.de>2017-11-30 17:08:31 +0000
committerJonas Hahnfeld <hahnjo@hahnjo.de>2017-11-30 17:08:31 +0000
commitfc473dee98fd8d2756983b9d039cd439e5a78f24 (patch)
tree24668270a601fa1c704f3b33a4895fec4c08f3ff /openmp/CMakeLists.txt
parentc7832045d5e8508713cd3353ea75ff8486add49f (diff)
downloadllvm-fc473dee98fd8d2756983b9d039cd439e5a78f24.tar.gz
[CMake] Detect information about test compiler
Perform a nested CMake invocation to avoid writing our own parser for compiler versions when we are not testing the in-tree compiler. Use the extracted information to mark a test as unsupported that hangs with Clang prior to version 4.0.1 and restrict tests for libomptarget to Clang version 6.0.0 and later. Differential Revision: https://reviews.llvm.org/D40083 llvm-svn: 319448
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index 8592c202cd23..cde822f21b8d 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -48,7 +48,7 @@ include(OpenMPTesting)
set(OPENMP_TEST_FLAGS "" CACHE STRING
"Extra compiler flags to send to the test compiler.")
-set(OPENMP_TEST_OPENMP_FLAGS "-fopenmp" CACHE STRING
+set(OPENMP_TEST_OPENMP_FLAGS ${OPENMP_TEST_COMPILER_OPENMP_FLAGS} CACHE STRING
"OpenMP compiler flag to use for testing OpenMP runtime libraries.")