summaryrefslogtreecommitdiff
path: root/compiler-rt/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler-rt/lib/builtins/CMakeLists.txt')
-rw-r--r--compiler-rt/lib/builtins/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/compiler-rt/lib/builtins/CMakeLists.txt b/compiler-rt/lib/builtins/CMakeLists.txt
index a302306cc302..c3e22a8f354f 100644
--- a/compiler-rt/lib/builtins/CMakeLists.txt
+++ b/compiler-rt/lib/builtins/CMakeLists.txt
@@ -3,14 +3,7 @@
# architecture-specific code in various subdirectories.
if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
- cmake_minimum_required(VERSION 3.13.4)
- if ("${CMAKE_VERSION}" VERSION_LESS "3.20.0")
- message(WARNING
- "Your CMake version is ${CMAKE_VERSION}. Starting with LLVM 17.0.0, the "
- "minimum version of CMake required to build LLVM will become 3.20.0, and "
- "using an older CMake will become an error. Please upgrade your CMake to "
- "at least 3.20.0 now to avoid issues in the future!")
- endif()
+ cmake_minimum_required(VERSION 3.20.0)
set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
project(CompilerRTBuiltins C ASM)