summaryrefslogtreecommitdiff
path: root/libunwind/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libunwind/src/CMakeLists.txt')
-rw-r--r--libunwind/src/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/libunwind/src/CMakeLists.txt b/libunwind/src/CMakeLists.txt
index cced6b4cf9e8..1a5f4e07b278 100644
--- a/libunwind/src/CMakeLists.txt
+++ b/libunwind/src/CMakeLists.txt
@@ -35,8 +35,7 @@ set(LIBUNWIND_ASM_SOURCES
# CMake doesn't work correctly with assembly on AIX. Workaround by compiling
# as C files as well.
if((APPLE AND CMAKE_VERSION VERSION_LESS 3.19) OR
- (MINGW AND CMAKE_VERSION VERSION_LESS 3.17) OR
- (${CMAKE_SYSTEM_NAME} MATCHES "AIX"))
+ (MINGW AND CMAKE_VERSION VERSION_LESS 3.17))
set_source_files_properties(${LIBUNWIND_ASM_SOURCES} PROPERTIES LANGUAGE C)
endif()