summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 2d7f853a9ac2..1783e0114291 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -92,17 +92,6 @@ include(LLVMCheckCompilerLinkerFlag)
include(CheckCCompilerFlag)
include(CheckCXXCompilerFlag)
-# CMake omits default compiler include paths, but in runtimes build, we use
-# -nostdinc and -nostdinc++ and control include paths manually so this behavior
-# is undesirable. Resetting CMAKE_{LANG}_IMPLICIT_INCLUDE_DIRECTORIES disables
-# this behavior. See https://gitlab.kitware.com/cmake/cmake/-/issues/19227 for
-# further details no this topic.
-#
-# TODO: We may want to consider filtering out only the paths that are within
-# the toolchain installation and leaving the system paths.
-set(CMAKE_C_IMPLICIT_INCLUDE_DIRECTORIES "")
-set(CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES "")
-set(CMAKE_ASM_IMPLICIT_INCLUDE_DIRECTORIES "")
check_c_compiler_flag("" LLVM_RUNTIMES_LINKING_WORKS)
if (NOT LLVM_RUNTIMES_LINKING_WORKS)