summaryrefslogtreecommitdiff
path: root/lobject.h
Commit message (Expand)AuthorAgeFilesLines
* Towards "to closed" local variablesRoberto Ierusalimschy2018-10-081-0/+4
* Removed extra information from RCS keyword stringsRoberto Ierusalimschy2018-08-231-1/+1
* new field 'nilvalue' in struct 'global_State' to avoid the use ofRoberto Ierusalimschy2018-06-151-4/+1
* field 'sizearray' in struct 'Table' changed to 'alimit', which canRoberto Ierusalimschy2018-06-151-2/+15
* no more 'luaO_nilobject' to avoid comparison of global variable addressesRoberto Ierusalimschy2018-06-011-7/+1
* no more 'luaH_emptyobject' and comparisons of addresses of global variablesRoberto Ierusalimschy2018-06-011-8/+28
* no more nil-in-tableRoberto Ierusalimschy2018-04-041-8/+2
* better names for macros for tags and types.Roberto Ierusalimschy2018-02-261-11/+11
* special compact representation for userdata with no user valuesRoberto Ierusalimschy2018-02-261-9/+28
* avoid variant tags with the same value of the original typeRoberto Ierusalimschy2018-02-251-9/+9
* first (parcial) implementation of 'keyin'/'removekey'Roberto Ierusalimschy2018-02-251-5/+12
* first version of empty entries in tablesRoberto Ierusalimschy2018-02-231-3/+27
* some reorganization in 'lobject.h'Roberto Ierusalimschy2018-02-221-187/+218
* details (comments)Roberto Ierusalimschy2018-02-211-19/+26
* userdata can have multiple user valuesRoberto Ierusalimschy2018-02-201-26/+34
* janitor work on castsRoberto Ierusalimschy2018-01-281-4/+4
* detail (comment)Roberto Ierusalimschy2018-01-281-2/+2
* detail (typo in comments)Roberto Ierusalimschy2017-11-231-2/+2
* back to 'CallInfo' (no gains with its removal)Roberto Ierusalimschy2017-11-071-31/+1
* fitting a StackValue structure into 32 bytes (for 64-bit machines)Roberto Ierusalimschy2017-11-061-8/+9
* no more useful fields in CallInfoRoberto Ierusalimschy2017-11-031-2/+16
* more fields moved out of 'CallInfo'Roberto Ierusalimschy2017-11-031-1/+12
* baby steps to remove 'CallInfo': keeping 'L->func' correctRoberto Ierusalimschy2017-10-311-1/+5
* new type 'StackValue' for stack elementsRoberto Ierusalimschy2017-06-291-11/+22
* 'lineinfo' in prototypes saved as differences instead of absoluteRoberto Ierusalimschy2017-06-271-4/+21
* no more 'DEADKEY'. Table traversals do not need to consider dead keys;Roberto Ierusalimschy2017-06-121-10/+12
* in hash nodes, keys are stored in separate pieces to avoid wastingRoberto Ierusalimschy2017-06-091-22/+76
* when assigning to a 'TValue', better assign only exact fields,Roberto Ierusalimschy2017-06-011-6/+6
* added 'cachemiss' field to prototype to avoid wasting time checkingRoberto Ierusalimschy2017-04-301-1/+2
* type 'L_Umaxalign' replaced by macro 'LUAI_MAXALIGN', which is also addedRoberto Ierusalimschy2017-04-241-3/+3
* Upvalues collected like everything else (with mark-sweep) insteadRoberto Ierusalimschy2017-04-111-5/+17
* do not eliminate varargs from functions that do not use varargsRoberto Ierusalimschy2016-08-011-2/+2
* allow 'set' macros to be used when 'L' is not available (as it wasRoberto Ierusalimschy2015-11-031-2/+2
* function prepares vararg only if it really uses them (chunksRoberto Ierusalimschy2015-10-281-2/+2
* macros 'getaddrstr' and 'getstr' unified (they do the same thing)Roberto Ierusalimschy2015-09-171-3/+3
* detail in macro 'checkliveness' + macro 'setobj2t' defined as anRoberto Ierusalimschy2015-09-081-15/+16
* small janitor workRoberto Ierusalimschy2015-09-081-28/+23
* using macros ('rttype' and 'settt_') to access "private" field 'tt_'Roberto Ierusalimschy2015-06-091-3/+3
* detail (removed unused macro VARBITS)Roberto Ierusalimschy2015-04-021-3/+1
* commentsRoberto Ierusalimschy2015-03-141-5/+5
* new macros 'chgfltvalue'/'chgivalue' (numerical for loop doesRoberto Ierusalimschy2015-03-021-1/+7
* size of short strings stored in a single byte, to reduce the sizeRoberto Ierusalimschy2015-01-161-3/+12
* 'setkey' -> 'setnodekey' (to avoid conflicts with POSIX)v5.3.0v5-3-0Roberto Ierusalimschy2015-01-051-2/+2
* new macro 'nvalue' (to convert an object to a float when we knowRoberto Ierusalimschy2014-12-191-1/+3
* `name' in comments changed to 'name'Roberto Ierusalimschy2014-10-251-7/+7
* better to use 'long' to represent UTF-8 code pointsRoberto Ierusalimschy2014-10-011-2/+2
* size for array part of a table ('sizearray') changed from 'int' toRoberto Ierusalimschy2014-09-041-2/+2
* new macro 'cvt2str' to better control whether numbers are convertibleRoberto Ierusalimschy2014-07-301-1/+2
* simpler definition for 'setobj' (trust the compiler for the assignment)Roberto Ierusalimschy2014-07-291-3/+9
* type 'Udata' refers directly to structure inside the union (unionRoberto Ierusalimschy2014-07-181-16/+29