summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2019-08-26 17:19:16 +0200
committerZdenek Kabelac <zkabelac@redhat.com>2019-08-26 17:24:37 +0200
commit55f1d8a2697c6641215604ee32181d7ead7b8d85 (patch)
tree38b28b6cd24d7353c28a1ec36ef1b82349ede2e4 /configure.ac
parenta50c127904a99b5862c323ddc76bfcf760dd0805 (diff)
downloadlvm2-55f1d8a2697c6641215604ee32181d7ead7b8d85.tar.gz
configure: check for prlimit
Update configure and make code compilable if prlimit() is not present. Since the code is suspicious do not cope yet with it's replacement with set/getrlimit().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 830edb8da..e3af0c446 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,7 +153,7 @@ AC_DEFINE([_REENTRANT], 1, [Define to use re-entrant thread safe versions])
################################################################################
dnl -- Check for functions
AC_CHECK_FUNCS([ftruncate gethostname getpagesize gettimeofday localtime_r \
- memchr memset mkdir mkfifo munmap nl_langinfo pselect realpath rmdir setenv \
+ memchr memset mkdir mkfifo munmap nl_langinfo prlimit pselect realpath rmdir setenv \
setlocale strcasecmp strchr strcspn strdup strerror strncasecmp strndup \
strrchr strspn strstr strtol strtoul uname], , [AC_MSG_ERROR(bailing out)])
AC_FUNC_ALLOCA