summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2023-02-16 23:41:02 +0100
committerZdenek Kabelac <zkabelac@redhat.com>2023-02-17 00:00:12 +0100
commitb9697acbd6b4283b430b5c6a9ced45676c54bc1d (patch)
tree8203b75861db7d6647796ed83ddb55fc43a817c2 /configure.ac
parent1cd71a5fe3f69d0a4c8c05babd4a7433682318b5 (diff)
downloadlvm2-b9697acbd6b4283b430b5c6a9ced45676c54bc1d.tar.gz
configure.ac: various minor updates
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b728ad096..86f4941d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1238,11 +1238,7 @@ AC_ARG_ENABLE(cmdlib,
CMDLIB=$enableval, CMDLIB="no")
AC_MSG_RESULT([$CMDLIB])
AC_SUBST([LVM2CMD_LIB])
-AS_IF([test "$CMDLIB" = "yes"], [
- LVM2CMD_LIB="-llvm2cmd"
-], [
- LVM2CMD_LIB=""
-])
+AS_IF([test "$CMDLIB" = "yes"], [LVM2CMD_LIB="-llvm2cmd"], [LVM2CMD_LIB=])
################################################################################
dnl -- Enable D-Bus service
@@ -1262,7 +1258,7 @@ AS_IF([test "$BUILD_LVMDBUSD" = "yes"], [
unset am_cv_python_pythondir am_cv_python_version am_cv_python_pyexecdir
unset ac_cv_path_PYTHON_CONFIG ac_cv_path_ac_pt_PYTHON_CONFIG
m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[ python3 python2 python dnl
- python3.9 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 dnl
+ python3.12 python3.11 python3.10 python3.9 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 dnl
python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 ])
AM_PATH_PYTHON([3])
PYTHON3=$PYTHON
@@ -1273,12 +1269,8 @@ AS_IF([test "$BUILD_LVMDBUSD" = "yes"], [
AS_IF([test -z "$PYTHON3_CONFIG"], [
AC_MSG_ERROR([python3 headers are required for --enable-python3_bindings or --enable-dbus-service but cannot be found])
])
- PYTHON3_INCDIRS=`"$PYTHON3_CONFIG" --includes`
- PYTHON3_LIBDIRS=`"$PYTHON3_CONFIG" --libs`
PYTHON3DIR=$pythondir
- AS_IF([test "$PYTHON3_BINDINGS" = "yes"], [
- PYTHON_BINDINGS="yes"
- ])
+ AS_IF([test "$PYTHON3_BINDINGS" = "yes"], [PYTHON_BINDINGS="yes"])
# To get this macro, install autoconf-archive package then run autoreconf
AX_PYTHON_MODULE([pyudev], [Required], python3)