summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ae8087..019631d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,8 +26,9 @@ dist_aclocal_DATA = \
autoconf-archive/m4/ax_valgrind_check.m4 \
$(NULL)
+# Here, plain m4 is being used to strip 'dnl' comments.
all-local: $(dist_aclocal_DATA)
- cat $^ | grep -v '^#' | grep -v 'AX_PACKAGE_REQUIRES' | sed -e 's/\<dnl\>.*//' | grep -o '\<AX_[A-Z0-9_]*[A-Z0-9]\>' | sort | uniq > used
+ cat $^ | grep -v '^#' | grep -v 'AX_PACKAGE_REQUIRES' | m4 | grep -o '\<AX_[A-Z0-9_]*[A-Z0-9]\>' | sort | uniq > used
cat $^ | grep ^AC_DEFUN | grep -o '\<AX_[A-Z0-9_]*\>' | sort | uniq > defined
diff -u used defined
rm -f used defined